Multibanco service (Easypay) is currently down
Incident Report for Shopkit
Resolved
This incident has been resolved.
Posted over 2 years ago. Mar 01, 2017 - 22:05 WET
Identified
The issue has been identified and a fix is being implemented.
Posted over 2 years ago. Mar 01, 2017 - 15:43 WET