Multibanco service (Easypay) is currently down
Incident Report for Shopkit
Resolved
This incident has been resolved.
Posted over 2 years ago. Jan 21, 2017 - 15:25 WET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 2 years ago. Jan 21, 2017 - 13:28 WET