Multibanco service (Easypay) is currently down
Incident Report for Shopkit
Resolved
This incident has been resolved.
Posted over 2 years ago. Apr 12, 2017 - 11:32 WEST
Investigating
We are currently investigating this issue.
Posted over 2 years ago. Apr 12, 2017 - 11:06 WEST