Network connectivity issues
Incident Report for Shopkit
Resolved
This incident has been resolved.
Posted over 1 year ago. Feb 22, 2018 - 10:15 WET
Investigating
We have identified network connectivity issues on our servers which causes external services to perform poorly.

We are monitoring the situation closely and will update as soon as possible.
Posted over 1 year ago. Feb 21, 2018 - 17:24 WET